Foro QNAP en español

Versión completa: Comparando mi nuevo Nas Qnap de 300 euros con el viejo de 100
Actualmente estas viendo una versión simplificada de nuestro contenido. Ver la versión completa con el formato correcto.
Tras mucho mirar he decidido cambiar mi viejo nas D-link DNS320L ( valor actual 100 euros ) por un flamante Qnap TS-251 ( 270 euros ) ( precios sin discos duros ) más potente que el anterior tanto en hardware como en sistema operativo y software y que recibí ayer y me gustaria compartir con vosotros mis primeras impresiones ( y sorpresas ) con el nuevo aparato comparándolo con el anterior modelo. Os informo que para la inicialización del Qnap había préviamente formateado mi ordenador el dia anterior e instalado un windows 10 enterprise de 64 bits usando firefox recien instalado tambien para la configuración.
Dia 1: Tras conectar el qnap al router y a la corriente eléctrica el qnap se me enciende solo. Con firefox entro en la configuración de mi router y veo que efectívamente lo detecta. A continuación le asigno al Nas una ip fija dentro del rango de ips del router. Procedo con firefox a entrar en la configuración del nas con la ip citada y me sale la pantalla de configuración rápida. Le pongo un nuevo nombre al nas, usuario y contraseña, compruebo la dirección ip, y me sale la opción predeterminada de formateo con discos estáticos en raid 1 ( 2 wd red de 2 teras ). Lo dejo así y empieza el formateo e instalación de servicios predeterminados. Al terminar me pregunta si quiero entrar en la configuración del nas y lo hago. Tras una serie de pantallas de bienvenida y avisos me sale que hay una nueva actualización del software del nas ( la tenía ya previamente descargada de la web oficial de qnap ) pero aun así le doy para que la descargue e instale ( no toco ninguna otra configuración del nas ). Se descarga perfectamente e empieza a instalarse. Cuando lleva un buen rato en el que veo que está instalando varias cosas me sale una pantalla que me indica que la actualización no se ha podido instalar ( PRIMERA SORPRESA ). Hay que comentar en este punto que tenia un mensaje de aviso que se estaba sincronizando el raid ( en ese momento al 0´7 % ) cosa que en mi anterior nas eso no sucedia ( lo de la sincronización, por lo menos visíblemente ) como tampoco en el viejo nas nunca me habia dado error de actualización. Como tenia descargada la actualización del qnap procedo a instalarla manualmente y ( SEGUNDA SORPRESA ) me vuelve a salir el mensaje de que no se ha podido instalar la actualización. Lo dejo así. Anteriormente me habia informado que con el software del qnap se podia hacer un formateo a bajo nivel de los discos duros y procedo a hacerlo. Para hacerlo anulo el raid 1 dejando los discos individuales. Observo ( TERCERA SORPRESA ) que la sincronización del raid sigue su curso ( en ese momento al 1´2 % ) a pesar de que el raid 1 estaba quitado. Decido que lo mejor es reiniciar el nas. Lo hago y tras una espera de 15 minutos en la que me sale una pantalla que me indica que esta reiniciando y que espere lo hace.

Dia 1 ( Continuación ) :
Al reiniciar me sale la pantalla de usuario y contraseña, la pongo y (CUARTA SORPRESA) me sale la configuración del nas con una nueva interfaz. Me doy cuenta de que la nueva actualización se había instalado a pesar de los mensajes de error citados anteriormente. Sin tocar nada más me voy a la configuración de formateo a bajo nivel del nas. Le doy, me salen los 2 discos duros individuales, selecciono los dos, escojo formateo lento, le doy a siguiente y ( QUINTA SORPRESA ) no salen más pantallas. Sigo en la misma pantalla dejandome volver atras. La cierro y compruebo por el sonido que los discos duros se estan formateando. Vuelvo a configuración de discos y estan desaparecidos ( normal porque el formateo a bajo nivel los bloquea para hacerlo). No se me indica de ninguna forma cuanto tiempo se va a emplear en el formateo ni su progreso así que decido ir echando un vistazo a los distintos apartados de la configuración del nas sin tocar nada. Mirando las opciones del nas y a los 3 minutos de hacerlo la configuración del nas se queda bloqueada ( SEXTA SORPRESA ) ( no me deja tocar nada ). Como ya es tarde cierro la ventana de firefox con la configuración del nas ( firefox no estaba bloqueado, tenia otra ventana abierta y funcionaba perfectamente ) y dejo al nas toda la noche sin tocar oyendo como se estaban formateando los discos duros. Mañana mas......

Dia 2: Observo que las luces de los discos duros del nas estan en verde sin parpadear ( señal de que el formateo ha finalizado ) y ( SEPTIMA SORPRESA ) la luz de estado del nas está apagada. Enciendo mi ordenador y accedo con firefox a la ip de configuración del nas llevándome la ( OCTAVA SORPRESA ) : mensaje de firefox que no puede acceder a esa página. Lo intento otra vez y lo mismo. Decido apagar el nas mediante el boton físico del mismo. Espero un poco y lo vuelvo a encender. Ahora si, luces correctas. Entro otra vez con firefox a la ip de configuración del nas y ( NOVENA SORPRESA ): Me sale una nueva y renovada interfaz de configuración rápida del nas. Ahora me deja escoger entre configuración para el hogar o para empresa. Elijo hogar. Vuelvo a configurar nombre del nas, usuario y contraseña y como novedad a la hora de formatear los discos me sale predeterminado formato thick pero no me sale ninguna opción de escoger el espacio reservado para las instantaneas. Lo dejo así y continuo y procede a hacerlo. Cuando lleva un rato ( ya ha formateado y está instalando servicios ) ( DECIMA SORPRESA ) me sale una pantalla de qnap en la que me dice que no se puede conectar al nas con un icono en pequeñito en el cual al darle lo intenta otra vez. Le doy varias veces sin resultado alguno y decido darle al botón de refresco de página del navegador. Esta vez si. Accedo sin problemas a la configuración del nas y tras varios mensajes de bienvenida compruebo que se está sincronizando el raid bastante más rápido que la primera vez e incluso me da un tiempo de finalización de unas 4 horas.  Aquí termina mi relato por el momento. Espero que a partir de ahora el nas vaya mejor porque comparándolo con el anterior no había tenido nunca tanto problema. Seguiré informando de mis nuevos problemas ( si los hubiera ).......
Se me olvidaba comentar que mi nuevo nas qnap lo he adquirido con una ampliación de la memoria del dispositivo a 4 gigas con lo cual los errores reportados no se deben a falta de memoria en el equipo.
Hola

Creo que ibas demasiado rápido y no le dejabas terminar algunas cosas.

La instalación del sistema no depende del tipo de raid. En realidad el sistema se instala en todos los discos a la vez en una partición en modo raid 1. Luego desde el asistente creas la partición de datos, que ahí si decides si es raid 0, 1 o discos simples.

El hacer raid 1 le lleva su tiempo. Yo habría esperado antes de abortar y es por aquí por donde habrás tenido problemas. Esos formateos y preparaciones no se paran ni al detener la Qnap, quedan detenidas y continúan al iniciar la máquina.

La cantidad de memoria en este caso no afecta a la rapidez de construcción de un raid.

Al final veo que lo has conseguido

Ya verás y espero que nos lo cuentes de que has ingresado en otra liga si lo comparas con el D-link.


Un saludo
Agur eta ondo ibili
Gracias por la explicación. Estoy seguro de los errores reportados sean debidos a la rapidez de mis acciones. De todas maneras y remitiéndome al título de este post comparando con mi antiguo nas ( mucho menos potente tanto de hardware como de software ) me esperaba más del nuevo nas teniendo en cuenta que el antiguo no sólo era más rápido ( aparentemente ) en la realización de cualquier acción sino que también lo hacía siempre sin errores. Y ya que estamos lanzo la siguiente pregunta para el que la quiera contestar. Comparando los dos nas y suponiendo con toda seguridad que el nuevo es más potente y mejor y con un software más avanzado y confiable, el realizar acciones con el como por ejemplo crear un raid y que se sincronice y que otras acciones tarde bastante más tiempo en ejecutarlas que mi antiguo nas ¿ es debido a que el nuevo nas las ejecuta con más seguridad y mejor ? ¿ tarda más para darle más confiabilidad al raid y a la seguridad de los archivos que albergue ?. En defensa del antiguo nas diré que en los años que lo he utilizado nunca se me ha colgado ni fallado. Y si lo he cambiado es porque ya no era compatible con algunos tipos de archivo, acceso con aplicaciones móviles deficiente, deficiente soporte técnico y de actualizaciones. No porque no funcionara bien. Del nuevo nas ( es pronto todavía ) pero me está decepcionando la estabilidad del sistema y la rapidez en las acciones a menos que alguno de vosotros me explique el porqué de éste comportamiento.
Yo estoy con Ganeko, deberías haber esperado a que sincronizase el RAID antes de tocar el firmware. Pero en cierto modo tambien estoy de acuerdo contigo, pues tal vez debería haber un bloqueo del equipo mientras sincroniza el RAID para evitar fallos.

Ya verás que de aquí en adelante te irá sin problemas.
Hola

Respecto a la creación del raid y su primer uso. Supongo que el sistema comprobará primero los discos y luego hará particiones. Es como si en Windows haces un formateo normal (tarda) o uno rápido .

En cuanto a estabilidad... a más filigranas y florituras, más posibilidades de fallo. Pero esto pasa en Qnap y en todos los sistemas.

Yo soy más amigo de sencillez y robustez, pero el mercado va hacia el diseño y la estética, la depuración del sistema parece que se lo encargan a los usuarios (betatester involuntarios ).

Recuerdo que cuanto usaba QTS 2.8.2 el sistema parecía más rápido en máquinas ARM, pero hay que ser honestos y decir que había muchas menos aplicaciones para elegir y había menos funciones de serie. Un gran salto se ha obtenido con la integración de OpenVPN, con los snapshoots y el hybrid backup.



Un saludo
Agur eta ondo ibili
Dia 6: Muy contento con el nas, despues de todos los problemas reportados parece que ahora ya va bien, va como un tiro. Ahora si se nota las mejoras en hardware y en sofware respecto al anterior nas. Configurado perfecto siguiendo los consejos publicados en este foro, seguridad, certificados, etc. Acceso externo con aplicaciones móviles perfecto. Sigo sin entender porque ha necesitado 2 dias para sincronizar el raid ( sin ningún mensaje ni aviso de que lo está haciendo, sólo el parpadeo de las luces verdes de los discos duros ) introduciendo 600 gigas de datos en el nas. Por el momento no utilizo las instantaneas ( el nas avisa de perdida de rendimiento al hacerlo ). No les veo utilidad por el momento ( si eliminas un archivo por error tienes la papelera de reciclaje para recuperarlo) y aparte tengo un disco duro externo de respaldo. La única duda que tengo es si desactivar o no el servidor web. No voy a poner ninguna web en el nas pero al desactivarlo el nas avisa de que otros servicios dejarán de funcionar y por el momento lo he dejado activo. Las 600 gigas de datos las he puesto en la carpeta homes ( error ) pero parece que es la única carpeta que no se puede compartir ni sincronizar con el software del nas ( sincronizar con la nube o con un disco duro externo conectado al nas si y además muy rápido) De todas maneras no hay problema porque desde windows si se puede hacer. Todo bien por el momento. Seguiremos informando.....
Hola
Ya te dije que es una máquina muy maja.
Lo de las instantáneas está muy bien y es gran acierto de Qnap de cara a ramsonware. Créeme que es muy importante el tenerlo si es posible.
Perderás rendimiento cuando se hace, pero el beneficio es innegable.



Un saludo
Agur eta ondo ibili
Gracias, lo tendré en cuenta. Y ya que he comentado el tema de las sincronizaciones desde windows hacia el nas os hablaré del mejor programa para hacerlo: el propio windows ( es válida cualquier versión ). Windows tiene la antigua consola de comandos ( que aún existe ) y la nueva windows powershell integrada en el sistema operativo y desde las cuales se puede lanzar el comando robocopy para copias y sincronizaciones de archivos desde el propio windows a cualquier disco duro externo o nas. Las ventajas que aporta este comando superando a cualquier programa de copia y sincronización de archivos ( gratuitos y de pago ) es que trabaja desde el propio núcleo de windows con lo que la copia y sincronización de archivos son totalmente estables y seguras. Y otra ventaja es que al trabajar desde el núcleo de windows cualquier copia o sincronización de archivos ( sean archivos grandes o múltiples archivos pequeños ) se realiza a velocidad ultrarápida ( superando en un 200% o más a cualquier otro programa. Si quereis información sobre este tema la encontrareis aquí:

https://norfipc.com/comandos/como-usar-c...mplos.html

Y si os sigue interesando el tema despues de leer la información del enlace anterior pero no os gusta complicaros la vida poniendo comandos manualmente en la consola de comandos ( o powershell ) podeis utilizar el programa Easy Robocopy ( gratuito ). Este programa emplea el comando robocopy para la copia y sincronización de archivos desde la consola de comandos pero la diferencia es que Easy Robocopy tiene interfaz gráfica como cualquier programa de windows. O sea, le decimos que carpetas queremos copiar o sincronizar ( admite cualquier forma de sincronización: incremental, etc ) escogemos el tipo de sincronización y ya está ( no hay que poner ningún tipo de comandos de consola, ya los pone el ). El programa lanza la consola de comandos, ejecuta el comando robocopy y los ajustes deseados y a trabajar. La velocidad de transferencia es ultrarápida puesto que usa el comando robocopy de la consola de windows. El programa lo podreis encontrar aquí:

http://www.tribblesoft.com/home-page/easy-robocopy/
Hola
Efectivamente robocopy es a Windows como rsync lo es a Linux.
La consola de Linux lleva mucha ventaja a la de Windows . Y tal como te pasa a ti, yo estoy acostumbrado a la de Windows.


Un saludo
Agur eta ondo ibili