[Tutorial] Configuración DDNS custom
#41
(21-10-2017, 10:00 AM)vibeju escribió: Sí, yo tampoco sé como escribirlo.
Al igual está como qpkg y sería añadir el script como hemos hecho con el artesanal. La verdad es que no lo he probado.

Además ahora estoy sin nas. Tenía muchos problemas con él. Acceso a carpetas por NFS, problemas con algunos qpkgs, etc... No iba fino desde que lo compré. Finalmente y tras varios tickets a Qnap, han "aceptado" que la placa base está estropeada y tras abrir un RMA, lo he mandado a Qloudea en garantía.

Saludos.

Vaya, en todos los años que llevo con esto de QNAP, eres la segunda persona a la que veo que su QNAP la ha fallado físicamente, el otro soy yo Sad  y hace bien poco.

Es raro porque mecánicamente son muy robustas.

Se que para determinados modelos empresariales tiene QNAP garantías de hasta 5 años (si de 5 Exclamation . Pero no para todos, Qloudea no me dijo nada y he comprado para la empresa una de rack de 8 discos que no está en la lista Angry
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#42
Pues ya es casualidad!
Yo lo errores los achacaba al firmware y tanta versión beta en qpkgs, pero parece ser que todo viniera dado por el fallo en la placa base.
Ya veremos cuando me lo envíen de vuelta reparado... Espero tener que tragarme todas las lindezas que he dicho sobre la marca.



Enviado desde mi iPad utilizando Tapatalk
  Responder
#43
wenas:

Siguiente este hilo he conseguido configurar el plexdrive, pero lo unico que no he conseguido es que se arranque en el inicio.
Si ejecuto el script de forma manual va bien.
Voy a pegar lo que he añadido en el archivo /etc/config/qpkg.conf
Código:
[plexdrive]
Name = plexdrive
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2017-10-01
Shell = /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/plexdrive
QPKG_File = plexdrive.qpkg
Author = monty

El archivo /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh contiene lo siguiente:

Código:
#!/bin/sh
/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c /share/CACHEDEV1_DATA/plexdrive/.plexdrive -o allow_other /share/CACHEDEV1_DATA/homes/admin/Plexcloud -v 3 --cache-file=/share/CACHEDEV1_DATA/plexdrive/cache.bolt

No se si podrias ayudar a mejorar este script añadiendo que si se inicia ejecute eso y si quiero pararlo ejecute lo siguiente:


Código:
fusermount -uz /share/CACHEDEV1_DATA/homes/admin/Plexcloud



Gracias por vuestra ayuda
  Responder
#44
Hola
Echa una ojeada a este otro tutorial.
http://www.qnapclub.es/showthread.php?tid=2114

Aquí hasta incluyo un qpkg que una vez instalado y si editas el archivo script .sh te permite añadir comandos distintos al arranque y a la detención.



Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#45
(04-11-2017, 11:34 AM)abufa escribió: wenas:

Siguiente este hilo he conseguido configurar el plexdrive, pero lo unico que no he conseguido es que se arranque en el inicio.
Si ejecuto el script de forma manual va bien.
Voy a pegar lo que he añadido en el archivo /etc/config/qpkg.conf
Código:
[plexdrive]
Name = plexdrive
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2017-10-01
Shell = /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/plexdrive
QPKG_File = plexdrive.qpkg
Author = monty

El archivo /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh contiene lo siguiente:

Código:
#!/bin/sh
/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c /share/CACHEDEV1_DATA/plexdrive/.plexdrive -o allow_other /share/CACHEDEV1_DATA/homes/admin/Plexcloud -v 3 --cache-file=/share/CACHEDEV1_DATA/plexdrive/cache.bolt

No se si podrias ayudar a mejorar este script añadiendo que si se inicia ejecute eso y si quiero pararlo ejecute lo siguiente:


Código:
fusermount -uz /share/CACHEDEV1_DATA/homes/admin/Plexcloud



Gracias por vuestra ayuda
Perdonad por mi ignorancia que es el plexdrive
Hasta luego lucas... beepp, beepp
[Imagen: XRAKW0em.jpg]
  Responder
#46
(04-11-2017, 02:34 PM)Rayeta76 escribió:
(04-11-2017, 11:34 AM)abufa escribió: wenas:

Siguiente este hilo he conseguido configurar el plexdrive, pero lo unico que no he conseguido es que se arranque en el inicio.
Si ejecuto el script de forma manual va bien.
Voy a pegar lo que he añadido en el archivo /etc/config/qpkg.conf
Código:
[plexdrive]
Name = plexdrive
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2017-10-01
Shell = /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/plexdrive
QPKG_File = plexdrive.qpkg
Author = monty

El archivo /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh contiene lo siguiente:

Código:
#!/bin/sh
/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c /share/CACHEDEV1_DATA/plexdrive/.plexdrive -o allow_other /share/CACHEDEV1_DATA/homes/admin/Plexcloud -v 3 --cache-file=/share/CACHEDEV1_DATA/plexdrive/cache.bolt

No se si podrias ayudar a mejorar este script añadiendo que si se inicia ejecute eso y si quiero pararlo ejecute lo siguiente:


Código:
fusermount -uz /share/CACHEDEV1_DATA/homes/admin/Plexcloud



Gracias por vuestra ayuda
Perdonad por mi ignorancia que es el plexdrive

Las gsuite de drive (google) son nubes con capacidad ilimitada...entonces para montar como una unidad esta nube se monta con el plexdrive, entre otras aplicaciones(rclone...etc) que hay para montar el drive.Pero el plexdrive esta preparada para el plex.

un saludo
  Responder
#47
Buenas

Estoy peleando con el auto arranque (autorun) y no soy capad de que cuando reinicio el nas, me aranque un programa y eso que está bien explicado, creo que es por el contenido del archivo autorun.sh
No lo entiendo ya que la ruta lo tengo bien, es donde tengo el binario (bin) y los archivos (etc)

Situación:

ruta
/share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh

antorun.sh
#! / Bin / sh
/mnt/HDA_ROOT/.config/cs/bin/ncam -b -c /mnt/HDA_ROOT/.config/cs/etc

ruta
/mnt/HDA_ROOT/.config/qpkg.config

[autorun]
Name = autorun
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2014-03-02
Shell = /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/autorun
QPKG_File = autorun.qpkg
Author = jjbm

Reinicio el nas y el programa lo tengo que arrancar manualmente.
En appcenter, está instalado autorun 0.1.

salu2
QNAP TS-251+ 8GB
2 HDD 3TB en Raid 1
  Responder
#48
(26-11-2017, 03:50 PM)jjzuria escribió: Buenas

Estoy peleando con el auto arranque (autorun) y no soy capad de que cuando reinicio el nas, me aranque un programa y eso que está bien explicado, creo que es por el contenido del archivo autorun.sh
No lo entiendo ya que la ruta lo tengo bien, es donde tengo el binario (bin) y los archivos (etc)

Situación:

ruta
/share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh
Comprueba que "/share/CACHEDEV1_DATA" existe en tu equipo ... puede ser otra

(26-11-2017, 03:50 PM)jjzuria escribió: antorun.sh
#! / Bin / sh
/mnt/HDA_ROOT/.config/cs/bin/ncam -b -c /mnt/HDA_ROOT/.config/cs/etc
Creo que debería ser algo similar al siguiente (aunque no entiendo que hace el comando que lanzas)

#!/bin/sh
/mnt/HDA_ROOT/.config/cs/bin/ncam -b -c /mnt/HDA_ROOT/.config/cs/etc

(26-11-2017, 03:50 PM)jjzuria escribió: ruta
/mnt/HDA_ROOT/.config/qpkg.config


[autorun]
Name = autorun
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2014-03-02
Shell = /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/autorun
QPKG_File = autorun.qpkg
Author = jjbm

Reinicio el nas y el programa lo tengo que arrancar manualmente.
En appcenter, está instalado autorun 0.1.

salu2

El contenido añadido a qpkg.config parece correcto, podrías eliminar la línea "Class = null"

¿has probado a lanzar por consola el comando  /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh?
¿que se supone que hace el autorun.sh? ¿es algo que se pueda anular o parar?

Lo de la versión es lo de  menos, es un dato que indicas en el qpkg.config
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#49
Si ves cuando lanzo el comando, me pone bad interpreter: Permission denied
Lo interpreto mal, por eso me pone permiso denegado
Tendría que cambiar la ruta
/share/CACHEDEV1_DATA
La puedo poner en???
/mnt/HDA_ROOT/.config/cs



Si existe la ruta
/share/CACHEDEV1_DATA

Este comando es para que me arranque manualmente el programa
#!/bin/sh
/mnt/HDA_ROOT/.config/cs/bin/ncam -b -c /mnt/HDA_ROOT/.config/cs/etc


Comando por consola
[~] # /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh
-sh: /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh: /: bad interpreter: Permission denied

saludos
QNAP TS-251+ 8GB
2 HDD 3TB en Raid 1
  Responder
#50
Haz un "cat /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh" y envianos una captura de la salida de pantalla.

Por cierto, en un tutorial [URL]QPKG para autoarranque

https://r.tapatalk.com/shareLink?share_f...are_type=t[/URL] puse como crear este qpkg ficticio, y al final del tutorial adjunté un enlace de descarga de un qpkg que lo hace TODO evitando la creación artesanal. Lo único que debería hacer es modificar el "auroarranque.sh" y meter tus órdenes.



Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder




Usuarios navegando en este tema: 1 invitado(s)