Nuevo QTS en camino
#51
(04-10-2021, 02:59 PM)yeraycito escribió: Si señor, Qnap ha sacado la versión " final " de QTS 5. Pero sólo, de momento, para algunos modelos de nas. Digo de momento, porque, por ejemplo, para el mio tengo disponible la Release Candidate pero no la versión final así que imagino que más adelante la tendré disponible. Es una lástima porque tenía pensado en cuanto saliera instalarla y poner en este post un tutorial con imágenes con la mejor manera de hacerlo.

La lista de nas que lo soportan, por el momento, es esta:

TS-X75, TS-531P, TS-X73A, TS-X90U, TS-X53S, TS-XA51, TS-XA82, TS-X89U, TS-X88, TS-X85U, TS-X85, TS-X82S, TS-X82, TS-X77, TVS-X71, TVS-X63, TS-X53B, TS-X51A, TS-131P_231P_431P_X31+_X31K, TS-X35, TS-X31X, TS-X31P2, TS-X31P3, QMiroPlus, Mustang-200.


Esta versión " final " aviso de que trae errores importantes:

- Some applications cannot access the NAS when secure connection and TLS 1.3 are enabled. This is due to a known issue in the applications. We will fix this issue in upcoming app releases.

- QTS 5.0.0 temporarily does not support certain file systems on external storage devices. To work around this issue, users can use HBS3 to back up files to external storage devices. Note that this workaround may require more CPU resources and increase backup task duration. We will soon fix this issue in an upcoming release.

- QTS 5.0.0 temporarily does not support certain third-party applications, utilities, or services.

La lista de cambios completa se puede ver aquí:  https://www.qnap.com/en/release-notes/qt...8/20211001

Después de ver todo esto mi opinión personal sobre esto es que es una AUTENTICA CHAPUZA en la que Qnap nos toma por idiotas riéndose de los usuarios presentando una versión " final " que más que eso parece la beta 2. Y no sólo no está terminada sino que la lanza para algunos y para otros no con la manifiesta intención de que actúen de conejillos de indias. Lo dicho, vergonzoso e indignante.
Buenas.
Visto lo visto me voy a esperar a que pulan esos errores y de camino te voy dando tiempo para que vayas haciendo esa guía que habías pensado hacer, cuando la actualización QTS 5 llegue a tu NAS.  Big Grin
Estoy contigo en que es incomprensible, al menos para mí, que saquen un sistema operativo con errores. Comprendería que saquen el S.O y surjan fallos y errores, pero lo que no entendido es que han sacado QTS 5 a sabiendas de los fallos que tiene.
En fin, seguiré esperando un poco más.
  Responder
#52
Hola

Bueno, por lo menos han dicho que errores tiene.
Los demás lo sacan y luego vamos descubriendo los errores.

No se que es peor
Pero en este caso prefiero saberlo con antelación
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#53
Después del lanzamiento de la versión final de QTS 5 para un número limitado de nas se acaba de lanzar una versión más actualizada de ese firmware para una mayor cantidad de dispositivos. Esta nueva versión sigue teniendo errores desconocidos pero ya son más reducidos y limitados a casos muy específicos. Aún así Qnap se protege advirtiendo que no soporta temporálmente ciertas aplicaciones o servicios de terceros.

La lista de cambios respecto a la versión inicial se puede ver aquí: https://www.qnap.com/en/release-notes/qt...8/20211020

Para los que no reciban la actualización recomiendo esperar a ver si la lanzan. Si no se recibiera una alternativa para los nas con HDMI sería Truenas: https://www.qnapclub.es/showthread.php?tid=3940

No voy a volver a hablar sobre la conveniencia de realizar una reinicialización del nas con QTS 5 y empezar de cero con el. Muchos simplemente actualizaréis y a funcionar. Para los pocos que os animéis a hacerlo os pongo un tutorial.

Para reinicializar el nas lo podemos hacer de dos formas. En mi caso he probado las dos y una de ellas no ha tenido el resultado que esperaba. Os lo explico. Se puede hacer de las siguientes formas:

1 - Acceder al nas - reinicializarlo - actualizar el firmware - instalar

2 - Acceder al nas - actualizar el firmware - reinicializarlo - instalar

La primera opción no ha ido bien. El proceso de reinicialización tardó más de 6 HORAS sin contar la posterior instalación. Lo sorprendente del caso es que después de reinicializarlo y a continuación indicarle el firmware nuevo cuando el nas arrancó seguía estando con el firmware antiguo. Lo que si había ocurrido era la eliminación de los volúmenes del nas y el consiguiente formateo de los discos duros. El que haya tardado más de 6 horas en realizar el proceso se podría explicar con un formateo a bajo nivel de los discos duros. Esta operación requiere un gran número de horas para realizarla y cuanto mayor sea la capacidad de estos discos más tiempo es necesario. Qnap no informa, como es natural en ellos, nada sobre este tema. Así que es una especulación mia.

Teniendo mi nas en ese estado ( firmware antiguo pero reinicialización hecha ) no me quedaba otra que actualizar el firmware. Después de eso tampoco me he quedado contento y he vuelto a reinicializar el nas esta vez ya con QTS 5. Así que con este último sistema voy a poneros el tutorial.

Antes de empezar dos cosas importantes:

1 - Reinicializar el nas supone la pérdida de todos los datos y configuraciones del nas

2 - Al hacerlo las conexiones de red del nas vuelven a sus valores por defecto, es decir, la ip del nas será la que le otorgue el DHCP del router.

Para reinicializar el nas se puede hacer también de dos maneras:

1 - Mediante el botón físico trasero del nas

2 - A través de la interfaz del nas

Lo voy a hacer con esta última opción

PRIMERA PARTE: REINICIALIZACION

Accedemos a nuestro nas y actualizamos el firmware a QTS 5. El nas se reiniciará igual que con otra actualización de firmware anterior.

Hecho esto accedemos a Panel de Control - Copia de seguridad/restauración - Restaurar los valores por defecto

De las opciones que nos aparecen escogemos la de Reinicializar el NAS

   

A continuación nos sale una ventana informando de lo que va a ocurrir y nos pregunta si al terminar el proceso queremos reiniciar o apagar el nas. La opción por defecto es el reinicio. Os recuerdo algo. Antes he comentado que mi primera reinicialización con el firmware antiguo tardó más de 6 horas. Como ahora ese paso ya lo tengo hecho el proceso ha sido instantáneo. Pero a vosotros es muy posible que tarde ese tiempo así que una buena opción, por si las moscas, es optar por la opción de apagado. Así tarde lo que tarde no hay que estar pendiente del nas y tampoco pasa nada por hacerlo así. Cuando termine el proceso el nas se apagará y al volver a encenderlo se retoma la instalación.

   

Se nos pide la contraseña del nas

   

Empieza una cuenta atrás

   

Ahora ocurrirán las cosas según hayáis escogido antes. Si habéis optado por reiniciar el nas la pantalla se mantendrá sin cambios hasta que termine el proceso y si lo apagais pues eso, cuando termine se apagará. Terminada la reinicialización pasamos a la segunda parte.

SEGUNDA PARTE: INSTALACION

Nos aparecen unas primeras pantallas

   

   

Iniciamos la instalación. Nos aparece una pantalla con la versión de firmware instalada. Como ya está puesta la última continuamos.

   

Se nos pide el nombre del nas, nombre de usuario y contraseña de administrador. Si pulsamos en el botón de ayuda correspondiente al cuadro de nombre de usuario se nos informa que se va a crear una cuenta de administrador con ese nombre que pongamos y también se nos dice que cuando la instalación termine la cuenta admin quedará dehabilitada.

   

Escogemos la zona horaria

   

Ajustes de red

   

Nos aparece un resumen de lo que va a ocurrir a continuación ( imagen recortada )

   

Ultimo aviso

   

Iniciando servicios

   

   

A continuación nos aparece la pantalla de inicio de sesión de toda la vida. Ponemos los datos de acceso y aparece esto

   

Nos obligan a aceptar los términos y condiciones. Accedemos por fin a la interfaz principal del nas. Nos salen varias ventanas. Una de ellas sobre el envío de datos a Qnap que podemos rechazar. También aparece otra ventana recordando que no hay ningún volumen en el nas. Desde que se inició la instalación hasta llegar a la pantalla principal ha llevado más o menos media hora. Os vuelvo a recordar que el proceso anterior de reinicialización puede llevar muchas horas.

   

   

Con esto doy por terminado el tutorial. Ahora tocaría crear volúmenes cosa que no toca explicar en este post. Me ha llamado la atención una cosa de la instalación. El que no se creen raids, antes se hacía durante la instalación. Ahora parece que se crean cuando creamos un Conjunto de Almacenamiento.

Conclusiones: 

1 - Reinicializar el nas y después actualizar el firmware e iniciar el sistema con el NO FUNCIONA. Grave error por parte de Qnap

2 - Terrible lo de la NO INFORMACION por parte de Qnap a la hora del tiempo empleado en la reinicialización sin informar de un posible formateo a bajo nivel de los discos duros.

3 - Aparte de los iconos demasiado grandes, para mi gusto, de la nueva interfaz, se nota y mucho una mayor fluidez en el sistema.

4 - Aparte de los errores comentados antes más el tiempo que se necesita para reinicializar el nas sigo considerando que es lo mejor que se puede hacer con el nuevo QTS 5.
  Responder
#54
(22-10-2021, 03:00 PM)yeraycito escribió: Después del lanzamiento de la versión final de QTS 5 para un número limitado de nas se acaba de lanzar una versión más actualizada de ese firmware para una mayor cantidad de dispositivos. Esta nueva versión sigue teniendo errores desconocidos pero ya son más reducidos y limitados a casos muy específicos. Aún así Qnap se protege advirtiendo que no soporta temporálmente ciertas aplicaciones o servicios de terceros.

...

Conclusiones: 

1 - Reinicializar el nas y después actualizar el firmware e iniciar el sistema con el NO FUNCIONA. Grave error por parte de Qnap

2 - Terrible lo de la NO INFORMACION por parte de Qnap a la hora del tiempo empleado en la reinicialización sin informar de un posible formateo a bajo nivel de los discos duros.

3 - Aparte de los iconos demasiado grandes, para mi gusto, de la nueva interfaz, se nota y mucho una mayor fluidez en el sistema.

4 - Aparte de los errores comentados antes más el tiempo que se necesita para reinicializar el nas sigo considerando que es lo mejor que se puede hacer con el nuevo QTS 5.

Buenos días.

Te agradezco mucho el tutorial, esta noche lo he puesto en práctica y NAS TS-251D CON 8Gb funcionando.

Como soy de leer rápido y por encima, la primera vez le di a "Restaurar valores predeterminados de fábrica..." y al reiniciarse el NAS no me salía la pantalla de inicio del NAS. Volví a leer tu tutorial con calma y volví a iniciar dándole esta vez a "Reinicializar el NAS", supongo que no haría falta volver a hacer esto, pero preferí seguir las instrucciones al "dedillo". Tengo dos discos de 4Tb en RAID 1 y no le llevó mucho tiempo ni la "Restauración" ni la "Reinicialización".

Después de la "Reinicialización", seguí las instrucciones y NAS funcionando.

De la información que almaceno en el NAS tengo una doble copia. La primera con el HBS guardada en Onedrive y una segunda copia con Acronis Cyber Protec Home Office guardada en sus servidores. Creado el volumen dejé toda la noche restaurando la copia con HBS y al despertar esta mañana todo funcionando. Ya no he tenido que echar mano de la copia de Acronis, todo estaba ok, pero me quedo más tranquilo con esta doble copia.

Ahora a seguir configurando el NAS tal como lo tenía, sobre todo el OpenVPN y ganas de probar el WireGuard a ver qué tal funciona.

El uso que le hago al NAS es para almacenar mis trabajos, a los que accedo en remoto mediante OpenVPN (probaré WireGuard) y guardar fotos. Desde que tenemos las plataformas de streaming casi no tengo películas, series o música que guardar. No es un uso fuerte del NAS y este TS-251D, cumple de sobras, sobre todo con los 8Gb, para lo que necesito. Es más creo que con Onedrive estaba cubierto, pero me pudo la curiosidad de probar un NAS y ahora veo que me he gastado el dinero en el NAS y sigo pagando Onedrive para utilizarlo como almacén de copias XD.

EDITO: Se me olvidaba decir que opino igual en lo de los iconos, se han pasado con su tamaño, demasiado grandes. Lo mismo con la letra de los iconos, muy grande. Por el resto, parece que va más fluido, pero como he dicho le doy un uso sencillo al NAS.

Un saludo y reitero mis gracias por el tutorial.
  Responder
#55
Como he comentado al principio mi primera idea fue reinicializar el nas con el firmware antiguo para dejar "todo limpio" y a continuación actualizar el firmware a QTS 5 e instalar. Pensé que era la mejor opción. Al hacerlo de esta manera mi nas empleó un gran número de horas para hacerlo pero terminó haciéndolo sin errores. El problema vino después al iniciar el nas y meterle QTS 5 con el resultado de que mi nas no "cogió el firmware" y se volvió a iniciar con el firmware antiguo.

Como dije en mi anterior comentario el nas tardó un montón de horas en reinicializarse. El motivo lo desconozco pero tiendo a pensar que el nas hizo un formateo a bajo nivel de los discos duros y por esto tardó tanto tiempo. Como he dicho antes todo se hizo sin ningún error.

Con el nuevo QTS 5 instalado volví a reinicializar el nas y ese proceso de reinicialización unido al de la posterior instalación no me llevó más de media hora. Por privado otro usuario me informó que en su nas renicializándolo siguiendo el tutorial sólo le había llevado media hora hacerlo.

Explicación: Es posible que hacer la reinicialización del nas con el firmware antiguo conlleve un formateo a bajo nivel de los discos duros cosa que no ocurre con el firmware nuevo, o sea, con QTS 5 y con el instalado al hacer una posterior reinicialización sólo se haga un formateo " normal " y por eso tarde mucho menos tiempo.

Como digo esto ocurre así pero los motivos son especulaciones personales.
  Responder
#56
Con la reinicialización ya hecha un video de la posterior instalación:

https://www.youtube.com/watch?v=2egb5RM6jas
  Responder
#57
(25-10-2021, 04:15 PM)yeraycito escribió: Con la reinicialización ya hecha un video de la posterior instalación:

https://www.youtube.com/watch?v=2egb5RM6jas
Gracias.


Yo he hecho una instalación "sucia" y la verdad es que los primeros días iba bastante lento pero con el trascurrir de los días cada vez va mejor. Muy contento.
Coraje y Corazón.
  Responder
#58
(27-10-2021, 10:09 PM)merlin64 escribió:
(25-10-2021, 04:15 PM)yeraycito escribió: Con la reinicialización ya hecha un video de la posterior instalación:

https://www.youtube.com/watch?v=2egb5RM6jas
Gracias.


Yo he hecho una instalación "sucia" y la verdad es que los primeros días iba bastante lento pero con el trascurrir de los días cada vez va mejor. Muy contento.


Si, ya comenté en su momento que lo notaba lento al inicio y como indicas ahora lo veo que responde mucho más rápido.
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#59
El primer software del mundo que mejora el rendimiento a los pocos dias sin tocarlo..... Tongue
  Responder
#60
Buenas tardes, quería comentaros mi experiencia con la actualización.
Tengo un Qnap con i9900K 64Gbram nvme y ahora todo perfecto, solo que no funciona la salida HDMI del NAS.

Lleva más de un año y medio sin problemas, servidor de maquina virtuale con 3 sistemas server2019, 1 RouterOS(TheDude), y server Plex

Al instalar la nueva versión, deja de arrancar el NAS, se queda en boot kernel.
He tenido que volver a la CPU original i5 y todo funciona correctamente, bajo de versión de QTS para poder volver a mi CPU i9

alguien mas ha tenido este problema?
Tenéis soluciones?
  Responder




Usuarios navegando en este tema: 1 invitado(s)