Configuración del NAS - https
#1
Buenos días,

después de mucho tiempo con el nas y activar las opciones recomendadas como forzar https, me surge una duda.

Tengo el nas cerrado al exterior, con la vpn habilitada. El tema es que cada vez que accedo desde la red local mi amigo chrome me salta con el típico aviso de certificados inválidos.

Hay alguna forma de configurar esta parte correctamente sin tener que poner alguna excepción o algo similar?

Un saludo
  Responder
#2
Hola

No, ya que accedes por ip local y no tienes instalado un certificado para esa ip local.

Podrías hacerlo si tu router tiene la opción de “nat lookback”.
Así cuando en tu red vas a la nas por la dirección https://tu nombre.myqnapcloud.com te presenta el contenido de la Ip de tu nas y como si tienes ese certificado, el navegador no “protesta” [emoji848]


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w) Ʀɐɯ0η
  Responder
#3
Gracias Gorka,

es interesante el tema del lookback pero me da que el router de vodafone me va a mandar a freir churros.

Por otro lado he encontrado este flag en chrome por si a alguno le interesa

chrome://flags/#allow-insecure-localhost

que permite acceder sin certificados en localhost.

Un saludo.
  Responder
#4
Hola

Lo que te comento yo, sirve luego para cualquier navegador.
Cada vez con más frecuencia, los navegadores nos van a dar guerra con el asunto de los certificados.
Tu solución me parece un buen apaño [emoji106][emoji106]

Comentar que a veces también aparece como nat-reflection.

Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w) Ʀɐɯ0η
  Responder




Usuarios navegando en este tema: 1 invitado(s)