OwnCloud 10.0.7
#1
He instalado el OwnCloud 10.0.7 junto a Qapache 2437.7213 que he descargado de https://www.qnapclub.eu/en/qpkg/246 y ha funcionado todo a la primera. El problema es que para acceder desde el exterior de mi red me pide https y no se como se configura. Alguien me podría echar una mano?
Responder
#2
Hola
Supongo que habrás de abrir puerto en tu router y al acceder desde el exterior tendrás que agregar la dirección para que la tome como permitida.

Desde casa no te fallará porque accedes por ip.
Prueba a acceder desde casa escribiendo la dirección web, te llevará a una web para agregarla.
Yo que hice yo (si no recuerdo mal) fué editar la dirección web a esa que te lleva cambiando el “https://direccion_ip/resto de dirección” por https://direcciónweb/resto de dirección”y la agregas desde el menú.

Se que también puede editar su archivo de configuración (un cfg) desde terminal y agregando la dirección. Previa parada del qpkg.



Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#3
Esta parte ya la tengo. Había equivocado una letra en el dominio. Ahora me gustaría configurar https para securizarlo pero no se como hacerlo.
Responder
#4
(11-02-2019, 12:07 PM)Sergio Rafael escribió: Esta parte ya la tengo. Había equivocado una letra en el dominio. Ahora me gustaría configurar https para securizarlo pero no se como hacerlo.
Hola
A ver si lo he entendido bien. Ya tienes configurado OwnCloud y has agregado las direcciones web permitidas. Y lo que te falta es agregar el certificado al servidor web
¿Correcto?

Si es así, has de agregar el certificado en el
servidor web de la Qnap. Se hace desde panel de control, seguridad, certificado y clave privada.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#5
En realidad no se por donde empezar. No se si existe algún tutorial paso a paso porque no he encontrado nada.
Responder
#6
(11-02-2019, 12:29 PM)Sergio Rafael escribió: En realidad no se por donde empezar. No se si existe algún tutorial paso a paso porque no he encontrado nada.
Hola
Ahora me has descolocado

Vamos por los requisitos previos:
¿Tienes activada en tu nas el acceso al servidor web por https? Se ve en panel de control, servidor web en Activar conexión segura HTTPS

¿Has abierto ese puerto en tu router para acceder desde el exterior a la ip estática de tu Qnap?

¿Has instalado algún certificado SSL en tu nas ? Por ejemplo uno de LetsEncryt con dominio myqnapcloud.com

Responde a lo que sepas y si algo no entiendes, ponlo que vamos explicándolo.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#7
(11-02-2019, 12:39 PM)Ganekogorta escribió:
(11-02-2019, 12:29 PM)Sergio Rafael escribió: En realidad no se por donde empezar. No se si existe algún tutorial paso a paso porque no he encontrado nada.
Hola
Ahora me has descolocado

Vamos por los requisitos previos:
¿Tienes activada en tu nas el acceso al servidor web por https? Se ve en panel de control, servidor web en Activar conexión segura HTTPS

Esto sí lo tengo.

¿Has abierto ese puerto en tu router para acceder desde el exterior a la ip estática de tu Qnap?

Lo acabo de abrir.

¿Has instalado algún certificado SSL en tu nas ? Por ejemplo uno de LetsEncryt con dominio myqnapcloud.com

Esta parte no se muy bien como va. De todas maneras uso noip.biz por si cambia algo.

Responde a lo que sepas y si algo no entiendes, ponlo que vamos explicándolo.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Responder
#8
(11-02-2019, 01:07 PM)Sergio Rafael escribió: Vamos por los requisitos previos:
¿Tienes activada en tu nas el acceso al servidor web por https? Se ve en panel de control, servidor web en Activar conexión segura HTTPS

Esto sí lo tengo.
Con esto te aseguras que el servicio https está en el servidor web. Ojo, que no es el mismo que usas para administrar tu Qnap (suele ser el 443).
Este último recomiendo no abrirlo al exterior.
(11-02-2019, 01:07 PM)Sergio Rafael escribió: ¿Has abierto ese puerto en tu router para acceder desde el exterior a la ip estática de tu Qnap?

Lo acabo de abrir.
Bien, eso significa que desde fuera de tu red, es posible acceder por el puerto indicado hacia tu Qnap (y no al resto de tu red doméstica)
(11-02-2019, 01:07 PM)Sergio Rafael escribió: ¿Has instalado algún certificado SSL en tu nas ? Por ejemplo uno de LetsEncryt con dominio myqnapcloud.com

Esta parte no se muy bien como va. De todas maneras uso noip.biz por si cambia algo.
Bien, que tengas un servicio de DDNS (noip, dyndns u otros) no quiere decir que tengas un certificado ssl con ellos.
Me explico. Una cosa es a que dirección vas y otra a qué nombre está el certificado. Si quieres que la página web muestre el candado verde, el certificado y la dirección del navegador web han de coincidir.

Qnap nos proporciona gratuitamente unos certificados emitidos por Lets Encrypt. La pega es que son del tipo nombresetumaquina.myqnapvloud.com

Pero para la mayoría de nosotros son operativos.
La forma de hacerlo es:
-actívanos myqnapcloud y asignamos un nombre único. Procura que sea descriptivo y fácil de recordar que luego hay que escribirlo p.e. “Hiperloop”
Una vez hecho esto lo que obtienes es una forma de acceder por DDNS (aparte de tu noip) mediante la dirección hiperloop.myqnapcloud.com

Ahora para agregarle un certificado ssl, vas al último aparatado de myqnapcloud llamado “certificado ssl”. Ahí tienes la opción de descargarlo e instalarlo.
Una vez hecho si escribes en un navegador
“Https://hiperloop.myqnapcloud.com:8081/OwnCloud” se te presentará la web de OwnCloud con su candado en verde (he supuesto que OwnCloud se publica por ese puerto, pero puede ser otro).
Si lo haces por “https://nombre.noip.biz:8081/OwnCloud” te saldrá un aviso de seguridad de que NO coincide el certificado con la web a la que visitas. Podrás agregar la excepción de seguridad y funcionar, pero el candado no estará en verde.

(11-02-2019, 01:07 PM)Sergio Rafael escribió: Responde a lo que sepas y si algo no entiendes, ponlo que vamos explicándolo.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Espero haberme explicado bien y que se haya entendido




Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#9
He configurado myqnapcloud he instalado el certificado y me lo marca todo ok pero no consigo conectar desde fuera.

El ownCloud entro en local por http://192.168.1.100:25638/ y desde fuera http://hiperloop.myqnapcloud.com:8285. Los dos ok.

Tengo abierto el puerto 8081. Si entro en https://192.168.1.100:8081 se abre la página de administración del NAS. Y si desde fuera entro en  https://hiperloop.myqnapcloud.com:8081 no hace nada.

No se en que parte he cometido el error.
Responder
#10
(11-02-2019, 08:27 PM)Sergio Rafael escribió: He configurado myqnapcloud he instalado el certificado y me lo marca todo ok pero no consigo conectar desde fuera.

El ownCloud entro en local por http://192.168.1.100:25638/ y desde fuera http://hiperloop.myqnapcloud.com:8285. Los dos ok.

Tengo abierto el puerto 8081. Si entro en https://192.168.1.100:8081 se abre la página de administración del NAS. Y si desde fuera entro en  https://hiperloop.myqnapcloud.com:8081 no hace nada.

No se en que parte he cometido el error.
Por
Lo que veo el puerto que usa tu OwnCloud es 25638 y es ese el que debes abrir.

Así desde el exterior accederás al https://hiperloop.myqnapcloud.com:25638/OwnCloud


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder




Usuarios navegando en este tema: 1 invitado(s)