Problemas con wordpress
#1
Hola a todos!

Acabo de instalar la ddbb y el wordpress y se ve bien en mi local. Creo que he leido que el wordpress tiene que ir bajo HTTPS. Si intento acceder desde fuera me pregunta algo del certificado y la pagina se ve mal y no va a ningun enlace como los del blog etc.  ¿Qué estoy haciendo mal?


Archivos adjuntos Imagen(es)
   
Responder
#2
(11-05-2019, 03:10 PM)pcolina escribió: Hola a todos!

Acabo de instalar la ddbb y el wordpress y se ve bien en mi local. Creo que he leido que el wordpress tiene que ir bajo HTTPS. Si intento acceder desde fuera me pregunta algo del certificado y la pagina se ve mal y no va a ningun enlace como los del blog etc.  ¿Qué estoy haciendo mal?
No hace faltan que esté bajo https si vas a acceder localmente. Si vas a hacerlo exteriormente a tu red si deberías instalar y activar algún tipo de certificado ssl.

Siempre que accedas a una pagina web mediante una dirección del navegador y NO coincida con el certificado instalado te dará aviso de error. Por ejemplo si tienes instalado en tu nas un certificado para “www.tudominio.com” te dará error si localmente accedes por https://ipdetunas. En cambio si accedes por https://www.tudominio.com” no te dará error porque coincide.

Puedes evitar el aviso interno si estás en tu red y durante la primera visita a la web, puedes agregar esa página como excepción y no te avisará más. Eso sí, el candado del navegador no estará en verde o cerrado, ya que sigue sin coincidir el certificado con la dirección web visitada.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#3
pero pq ni siquiera desde local no me permite navegar por mi wordpress ni siquiera me deja entrar al wp-admin
Responder
#4
(14-06-2019, 12:10 AM)pcolina escribió: pero pq ni siquiera desde local no me permite navegar por mi wordpress ni siquiera me deja entrar al wp-admin

vale ya lo arregle pero tengo otra duda. a ver una vez creado el dns y asociado a la nas y creado el host virtual si yo uso miweb.ddns.net me lleva a mi wordpress, y no me carga bien los css y no me deja navegar desde fuera de mi pc.  Es decir pincho al la pagina de blog y  me dice que no se puede acceder a este  sitio web ¿Que estoy haciendo mal?
Responder
#5
Hola
No estoy muy puesto en wordpress pero tiene la pinta de que tienes enlaces relativos.
Lo verás cuando accedes al blog y te indicará la dirección a la que quiere ir y no encuentra.

Pregunto desde mi ignorancia ¿Sabes si en la configuración de wordpress le puedes indicar la dirección web donde está alojada?

Esto seguramente te lo podrán indicar en algún foro específico de Wordpress ya que es todo un mundo.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#6
Muchas gracias no se me había ocurrido mirar la configuracion de wordpress y tenías toda la razón el problema era ese. Arreglado, mil gracias.
Responder
#7
(17-06-2019, 06:53 PM)pcolina escribió: Muchas gracias no se me había ocurrido mirar la configuracion de wordpress y tenías toda la razón el problema era ese. Arreglado, mil gracias.
Que sepas que lo dicho sin saberlo a ciencia cierta. Pero los síntomas iban por ahí.

Me alegro que te haya servido.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#8
Ahora vamos con la parte dos, Instalé docker container y puse wordpress todo ok. ¿Que hay que hacer para verlo desde fuera?
Responder
#9
Hola

Si la dirección a la que accedes para verla es tipo “192.168.55.45:45000/tuwordpress”
Has de abrir el puerto 45000 en tu router hacia la ip 192.168.55.45

Es importante que ese wordpress tenga siempre la misma ip local y lo tengas lo más asegurado posible. Piensa que va a estar accesible para todo el mundo (incluidos los chinos, rusos,...y toda la fauna de internet)



Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#10
Smile Smile Smile  Buena descripcion "y toda la fauna de internet" Smile Smile Smile
Un saludo y Gracias por vuestra colaboracion

QNAP TS-251+ - RAM= 8GB - HDD: 3TB - SSD: 500GB
http://ghbu.myqnapcloud.com

[Imagen: QNAP%20TS-251+.png]


Responder




Usuarios navegando en este tema: 2 invitado(s)