Cambio de discos
#1
Buenas tardes, después del problema extraño (https://www.qnapclub.es/showthread.php?tid=2997) que tuve me decidí a cambiar los discos por unos de mayor tamaño.
Tengo un TS-251A con dos discos de 2Tb en RAID 1 y quiero cambiarlos por dos discos de 4Tb y también ponerlos en RAID 1.

Se me ocurre hacer lo siguiente para no perder todas las configuraciones nuevamente (hace menos de dos meses tuve que configurar todo todo todo de nuevo por el maldito malware):
1. Saco uno de los discos de 2TB e instalo uno de 4Tb y reconstruyo el RAID 1... quedando un RAID 1 con un volumen de 2TB
2. Saco el segundo disco de 2TB y pongo el segundo disco de 4TB y reconstruyo el RAID 1... quedando nuevamente un RAID 1 con un volumen de 2TB
3. Extiendo el tamaño del volumen hasta los 4 TB.

Además tengo un backup de los datos más importantes en un disco USB.

Agradezco si me ayudan con las dudas que me surgen como por ejemplo si es correcto hacer este procedimiento (xD)?
Conviene hacer otro procedimiento? Es necesario respetar algún orden en el reemplazo de los discos?
Responder
#2
Hola
El procedimiento descrito es correcto.

Da lo mismo empezar cambiando el disco 1 que el disco 2.



Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#3
(24-07-2019, 12:08 AM)Ganekogorta escribió: Hola
El procedimiento descrito es correcto.

Da lo mismo empezar cambiando el disco 1 que el disco 2.



Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Muchas gracias!

Enviado desde mi Pixel 2 XL mediante Tapatalk
Responder
#4
Hola

Eso sí, ármate de paciencia que el proceso es lento.
Yo lo hice en varias máquinas con discos de 2, 3, 4 y 8 TB y todo fue bien.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#5
(24-07-2019, 05:27 PM)Ganekogorta escribió: Hola

Eso sí, ármate de paciencia que el proceso es lento.
Yo lo hice en varias máquinas con discos de 2, 3, 4 y 8 TB y todo fue bien.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Si lo se, probablemente haga un disco por día...
Apuro no tengo

Enviado desde mi Pixel 2 XL mediante Tapatalk
Responder
#6
Bueno por si a alguno le interesa paso a contar la experiencia lenta... del cambio de los discos y la problemática que se presentó.
En primer lugar luego de hacer el backup de todo procedo a apagar el NAS y hacer un buena limpieza que ya la necesitaba.
Vuelvo a conectar todo y compruebo que el NAS enciende correctamente.
Apago el NAS, saco el disco "2" de 2Tb e inserto uno de los discos de 4Tb, inicia correctamente y sin hacer nada, comienza la reconstrucción del RAID 1.
Hasta aquí todo bien... a la noche luego de 7hs aprox termina la reconstrucción reviso que todo funcione y estén reconocidos los discos como corresponde, reinicio el NAS y todo sigue igual.

Llegó el momento de poner el otro disco de 4Tb.
Apago el NAS y saco el disco "1" de 2Tb y pruebo iniciar el NAS (con un solo disco), el mismo nunca inció...
Lo dejé cerca de 2hs y si bien las luces se veían bien, no podía llegar al login ni funcionaba nada.
Vuelvo a poner el disco "1" de 2TB y el NAS inicia correctamente (quiere volver a sincronizar, pero no lo dejé, lo volví a apagar).

Aquí supuse entonces que sí había un orden en recambio de discos.
Apagué el NAS y volví a poner los dos discos de 2Tb originales... comienza la reconstrucción del RAID, aquí lo dejé toda la noche...
A la mañana del domingo saco el disco "1" de 2Tb e inicio el NAS con sólo el disco "2" de 2Tb, el NAS incia correctamente.
Por lo que volví a apagar el NAS y puse un disco de 4Tb en la primer bahía del NAS (disco "1"), comienza al reconstrucción... 7 horas más tarde compruebo que todo esté en orden...
Apago el NAS, saco el disco "2" de 2Tb... inicio el NAS sin problemas con un sólo disco de 4Tb.
Apago el NAS e inserto el segundo disco de 4Tb en la segunda Bahía, e inicia correctamente y comienza la reconstrucción del RAID con los dos discos de 4Tb...

Horas más tarde tenía funcionando el NAS con los dos discos de 4Tb sin problemas, pero con un RAID de 2Tb, aquí pensé que tenía más en claro como extender la capacidad pero no fue así por lo que tarde un poco en encontrar la función (terminé utilizando Google) y pudo realizar sin problemas la extensión de capacidad.

Por fin esta mañana pude comprobar que tenía el RAID1 de 4Tb con los dos discos correctamente instalados!

Espero no haberlos confundidos.
Responder
#7
Hola
No entiendo el motivo de que no te funcionase según tu primer procedimiento, yo lo veo correcto.
Pero veo que has sabido torear la situación .
Y es verdad lo que dices acerca de estirar el tamaño, no es tan inmediato el encontrarlo. ¿Buscaste en este foro? Lo digo porque si no hay nada sobre ello, estaría bien tener un hilo a modo de tutorial para otros.

De igual forma podías haber hecho los cambios de discos en caliente con la máquina en marcha sin apagarla en ningún momento.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#8
(29-07-2019, 06:54 PM)Ganekogorta escribió: Hola
No entiendo el motivo de que no te funcionase según tu primer procedimiento, yo lo veo correcto.
Pero veo que has sabido torear la situación .
Y es verdad lo que dices acerca de estirar el tamaño, no es tan inmediato el encontrarlo. ¿Buscaste en este foro? Lo digo porque si no hay nada sobre ello, estaría bien tener un hilo a modo de tutorial para otros.

De igual forma podías haber hecho los cambios de discos en caliente con la máquina en marcha sin apagarla en ningún momento.

Si mal no recuerdo era un tutorial propio de Qnap en la web oficial.
Con respecto a lo de hacerlo en caliente me parece que el TS-251A no permite "hotswap", sinceramente ni lo busqué pero estaba seguro que era así.
Responder
#9
Hola
Tienes razón, siempre creo que todos los
modelos tienen accesible las bandejas de disco y no es así.
Hay modelos en los que hay que retirar la carcasa para acceder a los discos.



Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#10
(30-07-2019, 06:28 PM)Ganekogorta escribió: Hola
Tienes razón, siempre creo que todos los
modelos tienen accesible las bandejas de disco y no es así.
Hay modelos en los que hay que retirar la carcasa para acceder a los discos.



Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
El ts251a tiene accesible desde afuera, recién estuve leyendo y si es hot swap así que para la próxima ya lo sé
Gracias!

Enviado desde mi Pixel 2 XL mediante Tapatalk
Responder




Usuarios navegando en este tema: 1 invitado(s)