Instalación de rTorrent
#1
Como veo que hay gente que está teniendo problemas con la instalación de rTorrent, me he animado a describir como lo hice yo en un sistema con QTS 4.3.3

Primero de todo diré que tenemos varias formas de instalar el paquete qpkg:
  • descargándolo de http://www.qnapclub.eu por el enlace o navegando por su web. Y luego abriremos el app center y seleccionaremos el paquete
   
  • instalando el repositorio de qnapclub.eu en nuestra nas y eligiéndolo desde el app center.
   

Hecho desde cualquiera de las dos formas tendremos, si nuestro sistema lo soporta, el icono en nuestra lista de apps instaladas.
La descarga es de unos cuantos MB, el paquete no es precisamente ligero.
En mi caso la versión que se instala es la 0.9.6.0503.

Al ejecutar la aplicación por primera vez nos pide usuario y clave. Y podremos usuario "rtorrent" y clave "admin"
   

Una vez dentro tendremos una venta con varias opciones
   

Lo primero cambiaremos la clave y usuario. Al hacerlo nos pedirá de nuevo credenciales para continuar.
En ese mismo apartado tendremos varios parámetros
  • Listening port 42000. Este puerto es el que abriremos que queremos gestionarlo externamente desde clientes móviles. En mi caso no lo uso porque prefiero tener las puertas cerradas Wink
  • UDP port to use for DHT 6881
  • desmarco uPnP en Data Transfer Ports y Remote Access Ports . Prefiero hacer las aperturas de puertos a mano y evitar en lo posible que lo haga el programa en el router si es uPnP.
  • En la sección de ancho de banda ajusto Download rate y Upload rate en función de la velocidad contratada, su simetria y de lo que queramos que use rTorrent para no interfererir en otros servicios. Por defecto pone unos 3MB de descarga y 768 KB de subida. Si tenemos 10MB/1MB asimétricos y queremos emplear la mitad para uTorrent pondremos 5120KB y 512KB. Si ponemos 0 usará lo máximo posible. El programa recomienda poner un 80% de nuestro ancho de banda para no estrangular a otros servicios.
  • Maximum allowed memory usage in MBytes pone sobre 640MB si nuestro sistema dispone de 1GB. Si tiene mas y en función de la que tengamos usada podremos aumentar esta cantidad.
  • Put new downloads in. Es la ruta absoluta de donde dejamos las nuevas descargas /share/Download/rtorrent/downloads
Si hacemos cambios pulsaremos al botón de "Save Changes" y luego al de "Home"

Para ir al entorno propiamente dicho del programa pulsamos en el botón de  "Log in" ubicado abajo a la izquierda

   


Tras pulsarlo veremos una ventana al mas estilo uTorrent, emule, transmission y otros gestores de descargas
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#2
Gracias por este trabajo

Enviado desde mi LG-H815 mediante Tapatalk
QNAP TS 253A
RAM: 4GB
Bahia 1: Disco WD Red 3TB
Bahia 2: Disco WD Red 3TB
RAID 1
 Responder
#3
Hola a todos.
No se que ha sucedido, pero, de pronto, de un dia para otro mi rtorrent ni sube ni baja nada... lleva asi ya mas de un dia.
¿Alguien sabe que puede estar sucediendo?
Estos son los mensajes que rtorrent me da en su ventana de registro:

[07.01.2018 15:26:29] La petición a rTorrent se ha excedido de tiempo.
[07.01.2018 15:27:07] Bad response from server: (500 [error,list]) Link to XMLRPC failed. May be, rTorrent is down?


Saludos y feliz año.
QNAP TS 253A
RAM: 4GB
Bahia 1: Disco WD Red 3TB
Bahia 2: Disco WD Red 3TB
RAID 1
 Responder
#4
Hola Juantel

Me pasa 3/4 de lo mismo. Supongo que será tras las últimas actualizaciones de firmware.
Habrá que probar lo típico: desinstalar y reinstalar. O echar una ojeada al foro https://qnapclub.eu/en/qpkg/376 para ver si el programador sabe algo.

Como no es nada oficial tendremos que buscarnos la vida .



Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#5
(08-01-2018, 07:12 AM)Ganekogorta escribió: Hola Juantel

Me pasa 3/4 de lo mismo. Supongo que será tras las últimas actualizaciones de firmware.
Habrá que probar lo típico: desinstalar y reinstalar. O echar una ojeada al foro https://qnapclub.eu/en/qpkg/376 para ver si el programador sabe algo.

Como no es nada oficial tendremos que buscarnos la vida .



Un saludo
Agur eta ondo ibili

Pues a mi me estaba funcionando bien, incluso de actualizar el firmware. Pero, de pronto dejo de hacerlo.
¿No sera que esta caida la red rtorrent?
Muchas gracias Gane... como no hablo ingles, si encuentras tu una solucion, o si consigues hacerlo funcionar, porfa, subela aqui.
Un abrazo y feliz año.
QNAP TS 253A
RAM: 4GB
Bahia 1: Disco WD Red 3TB
Bahia 2: Disco WD Red 3TB
RAID 1
 Responder
#6
(29-06-2017, 09:02 PM)Ganekogorta escribió: Como veo que hay gente que está teniendo problemas con la instalación de rTorrent, me he animado a describir como lo hice yo en un sistema con QTS 4.3.3

Lo primero cambiaremos la clave y usuario. Al hacerlo nos pedirá de nuevo credenciales para continuar.

¿Y cuales son las credenciales?
Porque yo he desinstalado rtorrent y lo he vuelto a instalar. Todo bien. Pero al cambiar el usuario y contraseña, trato de entrar y no me deja, ni con el usuario y contraseña por defecto, ni con los nuevos que he cambiado.
Subo captura de la pantalla que me sale.
Saludos.


Archivos adjuntos

Miniatura(s)
   
QNAP TS 253A
RAM: 4GB
Bahia 1: Disco WD Red 3TB
Bahia 2: Disco WD Red 3TB
RAID 1
 Responder
#7
Creo que admin rtorrent...te lo dice nada más instalarlo.


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#8
(08-01-2018, 07:10 PM)Ganekogorta escribió: Creo que admin rtorrent...te lo dice nada más instalarlo.


Un saludo
Agur eta ondo ibili

He vuelto a desinstalar e instalar rtorrent ya me deja con rtorrent y admin.
Pero sigue sin subir ni bajar nada.
Saludos y gracias.

¿A ti ya te funciona?
QNAP TS 253A
RAM: 4GB
Bahia 1: Disco WD Red 3TB
Bahia 2: Disco WD Red 3TB
RAID 1
 Responder
#9
Ya empieza a bajar y subir cosas... aunque todavia timidamente...
Saludos
QNAP TS 253A
RAM: 4GB
Bahia 1: Disco WD Red 3TB
Bahia 2: Disco WD Red 3TB
RAID 1
 Responder
#10
Ayer reinstalé y ya funciona.
No he probado dejando contenido torrent en la carpeta watch, pero si en añadir un archivo torrent.


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder


Usuarios navegando en este tema: 1 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 22-07-2018, 03:34 PM